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1. Introduction


1.1. Course notes

The material in this document is the main lecturing and course material for GEOG0027.


1.1.1. Educational Aims and Objectives of the Course

To enable the students to:


	Understand the nature of remote sensing data and how they are acquired


	Understand different types of remote sensing instruments and their missions


	Understand basic image representation and processing


	Understand how Earth Observation data can be combined with other sources of data and data techniques (e.g. GIS)


	Understand how EO data can be used in environmental science (particularly via classification and monitoring)


	Develop practical skills in these areas, which may be useful in planning of dissertations


	Develop links with the second year course on Geographic Information Systems Science and with othet courses as appropriate (e.g. hydrology, environmental systems)


	Lay the foundations for the third year course on Earth Observation






1.1.2. Course workload and assessment

Expected Course Load



	Component

	Hours





	Lectures

	8



	Private Reading

	80



	Supervised Laboratory Work (Computing)

	24



	Independent Laboratory Work (Computing)

	20



	Required Written Work

	10



	TOTAL

	142






Usual range 100-150 for 1/2 course unit

Timetable 2018-19



	Week/Day

	Thursday 11:00-12:00

	Thursday 12:00-13:00

	Friday 16:00-17:00





	Week 1

	.

	.

	11/1/19 LECTURE 1



	.

	.

	.

	Introduction to course



	Week 2

	17/1/19

	17/1/19

	18/1/19 LECTURE 2



	.

	COMPUTING 1: Image Display

	COMPUTING 1: Image Display

	Image Display and Enhancement



	Week 3

	24/1/19

	24/1/19

	25/1/19 LECTURE 3



	.

	DOWNLOAD

	COMPUTING 1: Image Display

	Spatial Information



	Week 4

	31/1/19

	31/1/19

	01/2/19 LECTURE 4



	.

	COMPUTING 2: Spatial Filtering

	COMPUTING 2: Spatial Filtering

	Image Classification



	Week 5

	04/2/16

	04/2/16

	05/2/19 LECTURE 5



	.

	COMPUTING 3a: Classification Intro

	COMPUTING 3: Classification

	Spectral Information



	Week 6

	READING WEEK

	READING WEEK

	READING WEEK



	.

	.

	.

	.



	Week 7

	21/2/19

	21/2/19

	22/2/19 LECTURE 6



	.

	Classification

	COMPUTING 3: Classification

	Environmental Modelling I



	Week 8

	28/2/19

	28/2/19

	1/3/19 LECTURE 6



	.

	COMPUTING 4: Project [https://geog0027-coursework.readthedocs.io]

	COMPUTING 4: Project [https://geog0027-coursework.readthedocs.io]

	Environmental Modelling II



	Week 9

	07/3/19

	07/3/19

	08/3/19



	.

	COMPUTING 4: Project [https://geog0027-coursework.readthedocs.io]

	COMPUTING 4: Project [https://geog0027-coursework.readthedocs.io]

	COMPUTING 4: Project [https://geog0027-coursework.readthedocs.io]



	Week 10

	14/3/19

	14/3/19

	15/3/19 Project [https://geog0027-coursework.readthedocs.io]



	.

	COMPUTING 4: Project [https://geog0027-coursework.readthedocs.io]

	COMPUTING 4: Project [https://geog0027-coursework.readthedocs.io]

	Discussion



	Week 11

	21/3/19

	21/3/19

	No lecture



	.

	COMPUTING 4: Project [https://geog0027-coursework.readthedocs.io]

	COMPUTING 4: Project [https://geog0027-coursework.readthedocs.io]

	.






Lectures in Pearson G07_

Computing in Pearson Building, UNIX Computer lab, Pearson 110a_



1.1.3. Assessment

100% Assessed Practical (3500 words) - submission date standard 2nd year submission date i.e. Fri 22th March 2019 (12 noon).

N.B.


	Penalties for late submission and over length WILL be applied


	Different arrangements for JYA/Socrates (make sure you inform the lecturers if this affects you)







1.2. Reading List


	Jensen, John R. (2006) Remote Sensing of the Environment: an Earth Resources Perspective, Hall and Prentice, New Jersey, 2nd ed.


	Jensen, John R. (1995, 2004) Introductory Digital Image Processing: A Remote Sensing Perspective (Prentice Hall Series in Geographic Information Science)


	Jones, H. G and Vaughan, R. A. (2010) Remote Sensing of Vegetation, OUP, Oxford.


	Lillesand, T., Kiefer, R. and Chipman, J. (2004) Remote Sensing and Image Interpretation. John






1.3. Use of these notes


1.3.1. Use online notes

The simplest way to use these notes is to read the documents online [https://geog0027-environmental-remote-sensing.readthedocs.io/en/latest/].



1.3.2. Use github notes

The main store for these notes is on gitbub [https://github.com/profLewis/GEOG0027] and you shpuld always be able to access (or download) the notes from there.



1.3.3. Use binder

Click on the binder link [image: Binder] [https://mybinder.org/v2/gh/profLewis/GEOG0027.git/master]

Thius lets you run the notebooks, rather than just viewing them.



1.3.4. Use Python locally

To use the notes as a notebook (assuming you have `git <http://git-scm.com>`__ and python [http://continuum.io/downloads] on your computer):


	Copy all of the notes to your local computer (if for the first time)

mkdir -p ~/DATA/working
cd ~/DATA/working

git clone https://github.com/profLewis/geog2021.git

cd geog2021







	Copy all of the notes to your local computer (if for an update)

cd ~/DATA/working/geog2021

git reset --hard HEAD

git pull







	Run the notebook

ipython notebook SpatialFiltering.ipynb
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2. Image Display and Enhancement using ENVI 5.5

Prof. P. Lewis [http://www2.geog.ucl.ac.uk/~plewis]

Prof. M. Disney [http://www2.geog.ucl.ac.uk/~mdisney]

Dr H. Heorton [http://www.ucl.ac.uk/earth-sciences/people/research-staff/dr-harry-heorton]

Department of Geography

University College London
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2.1. Aims

After completing this practical, you should have a reasonable idea of a range of basic functions within an image processing software, envi. You should also have started to make some sense of how the theory you are learning in the lectures can be used to manipulate image data.



2.2. Data

The datasets you need for this practical should be available to you on moodle ( https://moodle.ucl.ac.uk/mod/folder/view.php?id=2700004):


	ETM-190600 [https://www.dropbox.com/s/a6q9k52arscz7tm/ETM-190600?dl=0]


	ETM-190600.HDR [https://www.dropbox.com/s/rnclhr1jtu1c0x4/ETM-190600.HDR?dl=0]


	TM-280589 [https://www.dropbox.com/s/4aubve362tkqdnh/TM-280589?dl=0]


	TM-280589.HDR [https://www.dropbox.com/s/1bh5423bf0ka7u7/TM-280589.HDR?dl=0]




and you will need to download them into your personal N: Drive, e.g. N:\GEOG0027\data.

The data you will be using are:


	six wavebands of a Landsat TM [https://landsat.gsfc.nasa.gov/satellites/landsat-4/] image over Greater London, imaged on May 28th 1989. The data were obtained from the GLCF [https://geog.umd.edu/feature/global-land-cover-facility-%28glcf%29] which maintains a large database of (freely available) Landsat and other imagery. The data are at an original pixel spacing of 28.5 m, but have been resampled to a 25 m grid here. The data are in a Transverse Mercator projection with OSGB 1936
datum (Great Birtain Ordinance Survey).


	six wavebands (nominally the same wavelengths) of a Landsat ETM image with 25 m spatial resolution, covering the same spatial extent. These data were obtained on June 19th 2000. The data were obtained from Landmap which contains a database available to Universities and other users through an Athens login (done via the institution you are at).




The wavebands are:



	1

	2

	3

	4

	5

	6





	blue

	green

	red

	nir

	swir 1

	swir 2



	450-520 nm

	520-600 nm

	630-690 nm

	760-900 nm

	1550-1750 nm

	2080-2350 nm






The extent of the imagery is (Lat/Lon):


\[51^o 43'   9.23'' North, 0^o 36' 18.37'' West\]

to


\[51^o 16' 29.32'' North,  0^o 27' 24.60'' East\]



2.3. Introduction

*In this section, we will learn how to do a one time setup of the ENVI preferences and to load a false colour composite image*.

The purpose of this practical is for you to gain experience in image display and enhancement of EO data. The session will be normally run as two hour supervised practical. You may not complete all tasks in detail in that time, so once you get the hang of how to use the tool, move on to the next section and return later to think more about the remote sensing.

For this term we are anitcipating interuptions and abcenses though we are aiming to do all teaching face-to-face. We have set up the classes so that both options are available all the time by using UCL Desktop. The face-to-face teaching is in the departmental UNIX lab, and from these machines we access both MS Teams and UCL Desktop. ENVI will run straight away from UCL Desktop when you’ve navigated to it. There are several versions - use ENVI 5.5.3 (64 bit). DO NOT USE ENVI Classic!

There are alternate ways to work for those who wish: 1. The UNIX workstations also have the ENVI software installed, and you may find them better to use for image display. However when considering accessing saved work from multiple locations UCL Desktop is the easiest option for this course. 2. For personal machines the ENVI software is available from the UCL Software Database [https://swdb.ucl.ac.uk/package/view/id/142], with installation instructions for
mac [https://www.ucl.ac.uk/isd/how-to/how-to-install-envi-54-for-mac], for windows [https://www.ucl.ac.uk/isd/how-to/how-to-install-envi-54-for-windows]. Note that running ENVI on your own machine will require you to first run the license server.

These notes are not intended to be a comprehensive introduction to ENVI functionality. They serve as an introduction to remote sensing and image processing, presuming no prior knowedge. Further information on envi tools and fuctions can be found in the on-line help pages [https://www.l3harrisgeospatial.com/docs/tutorials.html].

Starting ENVI on UCL Desktop reveals an empty display.

[image: screen1]

For personal machines or on a UNIX machine you get a similar display.

[image: screen1]

The first time you use the tool, you may find it convenient to update the default data location.

You can access this via the File->Preferences menu. Then select Directories from the left hand column. Select Input Directory, select the little arrow, and find the directory we made and put the data in earlier.

On UCL Desktop: this window: [image: prefs]

for UNIX/Personal [image: prefs]

Typically, we will want to change the Input Directory and Output Directory to where you are currently working,

e.g. N:\GEOG0027\data on UCL Desktop Anywhere (where we save the data earlier, when navigating this will be under This PC), or /Users/xxxx/GEOG0027/data on a Mac, or /home/ucfxxxx/DATA/GEOG0027/data or similar on the UCL Unix system.

Make a note of where your image data are, so that you can find them the next time!

For versions below 5.5.3, you have to quit and restart ENVI for these changes to take effect.

You should now be able to open an image dataset: select File->Data Manager from the menu.

Click on the file tab, and choose an image file to open e.g. ETM-190600. Do not select the HDR files as these are header files. You may need to fist use the open icon (brown folder, top left) to find the file.

[image: open1]

From which you can select one or more ‘bands’ to open and assign to the red, green and blue colour guns.



2.4. Exploration

*In this section, we use various tools for exploring the image*.

Once you have loaded an image, explore how to pan and zoom around the image

Whilst doing this, examine some of the features you see in the image:


	The crosshairs can be used (and/or cursor value, looks like a “dropped pin”) to explore the geographical coordinates and the digital number (DN) in the three wavebands you are examining.


	How do the DNs compare for lighter/darker regions of the image?


	how could you check that the geographic coordinates seem sensible?


	try to relate the visual cues you see in the data to the DN values being shown


	use these ideas to interpret ‘colour’ as displayed in the image e.g. what does the ‘red’ colour mean and why is it so?








Find out how to Change RGB bands ... for the image you are viewing and use this to display e.g. a real colour composite.


	Try some different band combinations and make sure you can interpret the colour you see


	What happens if you put the same band onto R G and B? why?




*Make sure you make notes of what you have done and how you have done it so you can recall this later.*



2.5. Spectral Features

*In this section, we will learn how to consider spectral features and perform contrast enhancement*.

Clearly, we can ‘recognise’ much information in the image from spatial context.

[image: rgb]

But there are other ways we can visualise the data to aid our interpretation.

For example, if we select the Histogram stretch button: [image: custom]

then we obtain a histogram view of the data, within which we can apply a contrast stretch by ‘moving’ the upper and lower thresholds.

For greyscale:

[image: hist]

or three band colour:

[image: hist3]

This can be useful both for performing a contrast stretch

*experiment with this so that you understand what the linear contrast enhancement is doing to the image DN* You may find it useful to save some historgrams and images and put these in your notes. For UCL Desktop the easiest way to do quick saving is using screenshots. Find the On-Screen Keyboard and Paint apps. Use the combo of Windows-Icon+Shift+S, to start a screenshot on UCL Desktop, then go to Paint and Paste. The screenshot should appear in paint for you to
save. Make sure the On-Screen Keyboard doesn’t obstruct your image. You can also paste into a word doc if you want to take notes.

It is also of value in visualising the features of the histogram. The histogram shows the frequency of occurrence of the different DNs in the image. For example in the image above, we can describe the green waveband histogram (shown in green) as having two clear peaks and a long positive tail. The two peaks are most likely indicative of different land cover classes. The fact that there is a long positive tail may show a third ‘bright’ class present.

*explore the histograms shown by some of the wavebands you have access to here*

As you do this, think about the relationship between the informations shown in the image and that in the histogram.


	How could you try to use the histogram to perform a classification on the image into different land cover classes?


	What issues might you come across?


	Do some bands show better separatbility than others? if so, which (and why?)


	A histogram is a useful way of summarising the information in an image. In fact, we will often use even simpler descriptors to decsribe a frequency distribution such as this, one example being the mean and standard deviation. Would it be a good idea to describe these histograms in this way? If not, why not?




One way of extending our view of such summary data is to use a scatter plot (often called a ‘feature space’ plot). [image: tool] File->Select New Band

*locate the Scatter Plot Tool button, and display a scatter plot with the Red waveband (630-690 nm) on the x axis and the Near InferRed (700-900 nm) on the y axis*

Toggle the density slice button to show the scatter plot in colour (density slice)

[image: toggle1]

[image: toggle2]

You should now be able to define (‘draw’) regions onto the scatter plot, and the pixels within this specified region are then displayed in the defined colour on the image:

[image: scatter1]

[image: scatter1a]

*You should spend some time exploring this for different wavebands, as this concept forms the basis of many remote sensing algorithms (particularly those for classification)*

As you do this, think about how the scatter plot and histogram information are related and also think about how you might get the computer to describe the regions you have drawn in the feature space plot.

Think also about how using only one or two wavebands may be a limiting factor in classification (i.e. there is often information in other bands that may allow separability).

Try using Options -> Mean All on the scatter plot tool. This shows you the class means across all bands. This should allow you to better think about how the classes you have drawn might be separable in different wavebands.



2.6. Spectral Profiles

*In this section, we will learn how to do plot spectral profiles*.

Note that you may need to close the scatterplot tool before doing this.

Although we can display (up to) three bands of information in a colour composite, we often wish to know more information.

The various Display->Profiles tools can help in this regard as we can look at the DN in all wavebands (for a particular pixel).

The following show some example spectral profiles:

[image: spec1]

[image: spec2]

[image: spec3]

See if you can navigate your way to these locations and/or work out what ‘material’ is shown by the spectral profile. if you want to save these plots, make sure to give them a descriptive name that will make sense next time you find them.



2.7. Enhancement

*In this section, we will learn how to perform a variety of enhancement tasks*.

We have seen that ENVI has simple image display enhancement capabilities such as ‘brightness’ and ‘contrast’ variation via contrtol sliders. Open the Histogram stretch window to visualise the histograms again.

These are often useful first pass enhancement tools to enable you to more readily visualise features in the image.

Several ‘automated’ or semi-automated approaches also exist that may provide a useful enhancement under certain conditions.

These are available via a menu (Linear being the default) as:

[image: histlist]

For example,histogram equalisation is generally a useful visual enhancement method:

[image: nohist] [image: histo1]

*Explore the impact of various enhancement operations*

You may find it easiest to do this using a ‘greyscale’ representation (so there is just a single waveband to think about).

Think about how the different enhancements relate to the information in the histogram.

*In particular, explore how you can use image enhancement to more readily differentiate different DN levels in a particular area of the image (e.g. the river)*



2.8. Comparing Images

*In this section, we will examine some tools to use when comparing images*.

Often, we wish to compare features from more than one image (e.g. Landsat images taken over an interval of time).

There are several tools for exploring this in ENVI.

First, remove the current loaded images from ENVI (Note down how you do this!), then load two dataset ETM-190600 and TM-280589.

One immediately obvious thing you can do is simply toggle each dataset 'on and ‘off once it is loaded (using the dataset check box).

You can use tools we have seen above, such as the scatterplot to visualise the scatter between the two datasets (File->Select New Band):

[image: two]

You can also very usefully ‘draw’ on this scatterplot to identify interesting features:

[image: pink]


2.8.1. Transparency

Another option is to use the transparency slider [image: image0] to give different ‘weights’ of the two datasets. This might be useful, for instance to spot features that have changed between the two image dates:

[image: z1]

[image: z2]



2.8.2. Swipe and Flicker

Sometimes it is useful to ‘flicker’ between the various images or ‘swipe’ one over the other to spot features of (change) interest.

These can be done using the appropriate buttons on the command bar or under the Display option:

[image: flk]

[image: swipe]



2.8.3. Views

One other option is to change the number of ‘views’ on the screen display:

[image: views]

This will create new ‘views’:

[image: view2]

And you can drag and drop loaded datasets to the particular view you want.

*Use these various comparison tools to highlight areas of difference between the two images*




2.9. More Exploring

Some other interesting options to explore:


2.9.1. Annotation

On the control bar, you should see options for annotating the image. Experiment with annotating the image for a few features and work out how to save a ‘picture’ of what you have done (e.g. File -> Chip view to-> File ...):

[image: chip]



2.9.2. Google Earth

If you have tools such as Google Earth [http://www.google.co.uk/intl/en_uk/earth/] set up on the computer you are using, try File->Chip view to->Google Earth

[image: google]




2.10. Summary

The main aim of this practical is to get you used to using the image processing software tool envi.

In this practical, we have loaded two Landsat images of London and used various tools within envi to visualise the data and their information content.

In particular, we have learned about:


	Image Display


	False Colour Composites


	Real Colour Composites


	Greyscale display


	Spectral profiles






	Feature Space


	Histograms


	Scatterplots






	Enhancement


	Linear contrast enhancement


	Histogram equalisation












            

          

      

      

    

  

    
      
          
            
  

[image: image0]


3. Download data

In this section, you will learn how to order Landsat data from the USGS, including how to search only for the area we are interested in.

You will attempt to find two clear scenes (cloud-free or nearly so) for your area of interest.

You will then learn how to download the datasets.

Finally, we present one manual and one automated method for scaling the data, subsetting and producing a mask.

This is a skill you will need to complete the assessed coursework.

Once you have this skill, you can start collecting the datasets for the practical.

You do not need to use the ‘automated’ subsetting method: you can do everything manually if you wish.


3.1. Downloading and visualisation tools

The first task is to download the data that you will need.

There are several tools available to you for browsing and ordering Landsat data. See the USGS [https://www.usgs.gov/land-resources/nli/landsat/landsat-data-access?qt-science_support_page_related_con=0#qt-science_support_page_related_con] for a full description of the data products and where to order them.

You will most often be interested in surface reflectance products. These can be ordered through the USGS Earth Resources Observation and Science (EROS) Center Science Processing Architecture (ESPA) On Demand Interface [https://espa.cr.usgs.gov/].

The first time you visit the ordering service, you will need to register for an account [https://ers.cr.usgs.gov/register/]. Make sure you remember the usename and password you used for registration!

Once at the USGS Earth Resources Observation and Science (EROS) Center Science Processing Architecture (ESPA) On Demand Interface [https://espa.cr.usgs.gov/] site, make yourself aware of the information on surface reflectance [https://www.usgs.gov/land-resources/nli/landsat/landsat-surface-reflectance?qt-science_support_page_related_con=0#qt-science_support_page_related_con].



3.2. Select Landsat Scenes

To select a particular landsat scene, go to the Earth Explorer [https://earthexplorer.usgs.gov] site.

Enter the place you are interested in, in the Search Criteria (e.g. try: London, England) or select an area on the graphic using the Use Map polygon option.

Under Data Sets, look in Landsat -> Collection 1 Level 1 and check all of the boxes that have surface reflectance data. This will be for different sensors in the Landsat series (LS4-5, LS-7, LS-8).

You may wish to set a cloud cover limitation (e.g. 10%) under Additional Criteria.

Click on ‘Results’ and look at a few of the images. In particular, you should look at which ``PATH` and ROW <https://landsat.usgs.gov/landsat_acq>`__ is appropriate for the area you want data for. This could, for example be

Path 201
Row 24





Now, you can go back to the Search Criteria and enter just the path/row that you want, and/or just go through and add the files you want to download to the basket. This is the bar you have: Footprint, Overlay, Compare, Metadata, Download, Bulk Download, Order Scene, Remove

[image: options]

The first two are good for looking at, checking the cloud cover, and image cover. Choose either Download, or Bulk Download to get the full image. Select the GeoTIFF, the largest file.

For bulk download you can the view the basket, and submit the order. For this practical I suggest the DOWNLOAD option, getting immediate access to an image.

You should first try the Bulk Donwload with a small number of datasets, but it is quite straightforward to order many scenes if you need them.

If the order has worked, you will receive an email and also a notification when the data are ready for download. The order can be checked here https://dds.cr.usgs.gov/queue/orders/.
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4. Spatial filtering using ENVI 5.5


4.1. Aims

After completing this practical, you should be able to answer the questions: Which type of filter should I use for a given filtering application? What impact will the size and shape of the filter have on the output? You should have some understanding of the process (and issues) of spatial filtering of EO data using ENVI.



4.2. Data

The datasets you need for this practical are available from (skip this step if you’ve already downloaded them for the Image Display practical):


	ETM-190600 [https://www.dropbox.com/s/a6q9k52arscz7tm/ETM-190600?dl=0]


	ETM-190600.HDR [https://www.dropbox.com/s/rnclhr1jtu1c0x4/ETM-190600.HDR?dl=0]


	TM-280589 [https://www.dropbox.com/s/4aubve362tkqdnh/TM-280589?dl=0]


	TM-280589.HDR [https://www.dropbox.com/s/1bh5423bf0ka7u7/TM-280589.HDR?dl=0]




You should download these data and put them in a directory (folder) that you will remember!

The data you will be using are:


	six wavebands of a Landsat TM image over Greater London, imaged on May 28th 1989. The data were obtained from the GLCF which maintains a large database of (freely available) Landsat and other imagery. The data are at an original pixel spacing of 28.5 m, but have been resampled to a 25 m grid here. The data are in a Transverse Mercator projection with OSGB 1936 datum.


	six wavebands (nominally the same wavelengths) of a Landsat ETM image with 25 m spatial resolution, covering the same spatial extent. These data were obtained on June 19th 2000. The data were obtained from Landmap which contains a database available to Universities and other users through an Athens login (done via the institution you are at).




The wavebands are:
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	blue

	green

	red

	nir
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	swir 2



	450-520 nm

	520-600 nm

	630-690 nm

	760-900 nm

	1550-1750 nm

	2080-2350 nm






The extent of the imagery is (Lat/Lon):


\[51^o 43'   9.23'' North, 0^o 36' 18.37'' West\]

to


\[51^o 16' 29.32'' North,  0^o 27' 24.60'' East\]



4.3. Introduction

*In this section, we load the image data we wish to explore*.

The purpose of this practical is for you to build on practical 1 and learn about the process of spatial (convolution) filtering.

Note that convolution is a mathematical operation involving the modification of one function by another to produce a third (output) function. In spatial fitering this implies the operation of a filter (one function) on an input image (another function) to produce a filtered image (the output).

The session will be normally requiring at least two hours of effort. You may not complete all tasks in detail during the live session, so once you get the hang of how to use the tools, move on to the next section and return later to think more about the remote sensing.

There is a good material for this in text books (e.g. Jensen, Curran etc.) and some of this is online e.g. much of the Jensen material.

First, obtain and then load the TM and ETM images of London that we used in a previous practical.

View the ETM image as a FCC.

[image: fcc1]



4.4. Convolution filtering

*In this section, we use various tools for image convolution*.

A description of the various options for convolution and morphology are as envi help pages [http://www.exelisvis.com/docs/ConvolutionMorphologyFilters.html]. You should have a quick read over this if you are not familiar with the types of filter we will be using.

These operations are available via the Toolbox menu:

[image: toolbox2]

[image: conv]

*Apply a high pass filter (the one shown above) to the dataset*

Now Display this and the original dataset using Views->Two Vertical Views with the convolution result in the left.

You should then Views->Link Views to ‘geo-link’ the two views (creating a new link, clicking on the left view as the ‘anchor’ and then the right as the ‘reference’), so that moving around or zooming in one view is performed the same for both views. Make sure to move around the views to match each other before linking them (one simple way is to ‘Zoom to full extent’ for both views).

[image: link]

*Make sure you make notes of what you have done and how you have done it so you can recall this later.*

Now, find an interesting part of the image, for example Richmond Park, and try to understand how the filter is operating over the features you see.

You might find it easiest to use a greyscale image for this rather than false or real colour.

[image: richmond1]

You may find it useful to examine horizontal or vertical profiles of the original satellite data:

[image: profiles]

You may need to zoom in to the image to see the detail of the transect, but what you should be interested in examining is the relationship between features in the original dataset and the high-pass dataset.

For instance, looking at the NIR band, for a transect going over Richmond Park we see higher DN over the park than surrounding (urban) areas (why?) in the original data. In the corresponding high pass filtered dataset (below), we see variation in the filtered result around zero, with some ‘larger’ features (spikes).

Consider carefully the numerical values in the convolution kernel:
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	_
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	-1

	-1



	-1
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	-1



	-1

	-1

	-1






*What does it indicate when there is a positive (or negative) spike in the filtered transect?*

*Why is there a number 8 in the centre of the filter?*

*what does the filter produce if the image data are constant? (‘flat’)*

*what does the filter produce if the image data show a step change? (see e.g. resevoirs)*

[image: transdd]

[image: profile3]



4.5. Convolution

To think some more about this, it can be instructive to consider filtering in one dimension (rather than the two dimensions of an image). To aid this, 